Gestion de Contenu, de Communauté et de groupes de travail collaboratif - Open Source, français, sécurisé, stable et performant

  • MODULES

    Pour étendre les nombreuses fonctionnalités disponibles de base - modules.npds.org est à votre disposition.

    Des modules complémentaires, une communauté de développeurs active, des forums pour vos questions ... NPDS  est aussi une plateforme de développement !
  • STYLES

    Vous cherchez des thèmes graphiques pour votre portail ou votre communauté : styles.npds.org est à votre disposition.

    Des thèmes du plus simple au plus sophistiqué. Des thèmes facilement modifiables et toujours en Open-Source - Laissez simplement parler votre imagination !
  • BIBLES

    La documentation indispensable pour personnaliser et exploiter toute la puissante de NPDS  est à votre disposition sur bible.npds.org.

    Vous pouvez participer à l'effort de documentation - rien de plus simple : contactez un membre de la Team de développement et nous vous ouvrirons un compte sur le Wiki !
Devenir membre    |    Identifiant : Mot de Passe : -
Au delà de la gestion de contenu 'classique', NPDS met en oeuvre un ensemble de fonctions spécifiquement dédiées à la gestion de Communauté et de groupes de travail collaboratif.
Il s'agit d'un Content & Community Management System (CCMS) robuste, sécurisé, complet, performant et parlant vraiment français.

Gérez votre Communauté d'utilisateurs, vos groupes de travail collaboratif, publiez, gérez et organisez votre contenu grâce aux puissants outils disponibles de base.
  • Multi langues (Français, Anglais, Allemand, Espagnol, Chinois)
  • Respect des standards : UTF8, XHTML, CSS, ...
  • Système de blocs avancés
  • Installation et administration complète et centralisée
  • Editeur HTML intégré
  • Gestionnaire de fichier en ligne
  • Gestion des groupes de membres
  • Ecriture collaborative de documents (PAD)
  • Forums évolués
  • Mini-sites (pour les membres et les groupes de travail)
  • Chat temp réel
  • Système de News et de rubriques complet (édition, révision, publication)
  • ...
Gratuit et libre (Open-Source), développé en PHP, NPDS est personnalisable grâce à de nombreux thèmes et modules et ne requiert que quelques compétences de base.
NPDS Workplace - groupe de travail collaboratif
 NPDS WorkSpace - tous l'univers du travail collaboratif.
Modéré par : developpeur jpb Jireck 
Index du Forum » » Bugs, Probs ... » » Pas de titre dans les Flux RSS  
3 pages [ 1 | 2 | 3 ]
AuteurPas de titre dans les Flux RSS
gregland
33    

gregland
  Posté : 20-03-2013 18:03

Bonjour
Depuis que je suis passé a NPDS REvolution WS, je rencontre un soucis au niveau des flux Rss et je n'arrive pas a trouver de solution pourtant j'ai pas mal bidouillé....
Ce n'est pas super gênant en soit, mais moi ça me dérange ;)

Voilà mon problème :
Dans les nouveaux posts, le Flux Rss n'inscrit pas le titre de l'article.
Ce problème n'apparait pas lorsque des anciens posts (Avant le passage en REvolution) sont mis à jour.

Vous pouvez voir le problème à cette adresse http://gregland.net/backend.php

Auriez vous une idée de ce qu'il se passe?
Mon fichier backend.php a bien été mis à jour, je l'ai comparé a l'archive de npds.org.
Peut être un problème de thème (Permanent-Double-Side), mais à part les images il est semblable au thème de npds.org

Merci d'avance !

Message édité par : gregland / 20-03-2013 18:42


  Profil  Citation   
developpeur
24560       
 

developpeur
  Posté : 20-03-2013 21:57

j'ai regardé votre site - rien de spécial et effectivement la balise title du flux RSS n'est pas renseignée ... sauf que backend.php est sensé le faire - ???

1 - Essayez de remettre un backend.php d'origine Rew 11 WS
2 - Il doit y avoir un lien avec la base (peut-être)

A suivre donc

  Profil  E-mail  www  Citation   
gregland
33    

gregland
  Posté : 20-03-2013 22:31

Merci a toi pour la réponse.
Pour le fichier backend.php il est identique a la version d'origine REv 11 WS...

Le problème viendrait alors de la BDD? (C'est pas forcément une bonne nouvelle...)

  Profil  Citation   
gregland
33    

gregland
  Posté : 20-03-2013 22:53

Je viens de faire un test juste en mettant test3 dans le titre et dans l'article et je n'ai plus le problème...
Il y aurait un caractère dans l'article qui gênerait?

Et bizarrement aussi dans les fichiers ultramode.txt et net2zone.txt, les titres sont bien présents...
Par contre il manque la balise d'ouverture dans les fichiers xml RSS.

J'ai importer ma table "stories" dans une version de Rev en locale et les titres ont bien générés dans le flux Rss...

Une idée?

Message édité par : gregland / 20-03-2013 23:32


  Profil  Citation   
gregland
33    

gregland
  Posté : 21-03-2013 17:49

Bon j'ai trouvé quelque chose...
C'est un problème d'accents...
A chaque fois que le titre a un accent, le flux RSS est mal généré (Sans titre pour l'article qui a un accent)

J'ai supprimé tous les accents des titres et effectivement le flux est bien généré...

mais... ça ne me donne toujours pas la solution pour mettre des accents dans les titres

Help !

  Profil  Citation   
developpeur
24560       
 

developpeur
  Posté : 25-03-2013 21:52

Su NPDS.ORG il y a bien des news avec des accents et le RSS est bien généré donc pour ton site cela devrait être la même chose ?

Tu est en UTF8 ?

  Profil  E-mail  www  Citation   
gregland
33    

gregland
  Posté : 25-03-2013 22:20

Je suis d'accord avec toi.... J'avais vérifié aussi que sur npds.org le problème n'était pas présent...
Effectivement je suis en UTF8 (d'ailleurs je n'ai ce problème que sur les titres et non les articles, ce qui est encore plus étrange...)

Message édité par : gregland / 25-03-2013 22:36


  Profil  Citation   
developpeur
24560       
 

developpeur
  Posté : 25-03-2013 22:46

dans backend.php le titre support un traitement de plus à savoir :

$item->title = preview_local_langue($backend_language, str_ replace(""","\"",$title));



Si tu enleve le str_replace pour voir ?

  Profil  E-mail  www  Citation   
gregland
33    

gregland
  Posté : 26-03-2013 00:39

Dans le backend.php, j'ai donc remplacé :

$item->title = preview_local_langue($backend_language, str_ replace(""","\"", $title)); 


par

$item->title = preview_local_langue($backend_language, $title);


et supprimé le cache dans le dossier cache
et ça me donne la même chose...

Merci de t'intéresser a mon problème....

Message édité par : gregland / 26-03-2013 00:40


  Profil  Citation   
gregland
33    

gregland
  Posté : 26-03-2013 01:02

Attend...
Pour l'UTF8, je pensais que tu parlais de la Bdd (l'import de ma base), mais je suppose que tu parlais de l'option dans Admin/MetaTags) et effectivement, je n'étais pas en UTF8, mais en iso88591...

Donc le problèùe est réglé comme celà pour les titres du Flux..., mais par contre, je me retrouve avec des textes (pas dans les articles, mais dans les termes de NPDS qui sont plus au bon encodage, comme par exemple le mot "déconnexion" pour déconnecter l'utilisateur... les mois (février par exemple)...

C'est cool tu as géré... maintenant je dois corriger ce nouveau problème...

Message édité par : gregland / 26-03-2013 01:13


Message édité par : gregland / 26-03-2013 01:13


  Profil  Citation   
bartok
294     

bartok
  Posté : 26-03-2013 05:35

Citation : gregland 
par contre, je me retrouve avec des textes (pas dans les articles, mais dans les termes de NPDS qui sont plus au bon encodage, comme par exemple le mot "déconnexion" pour déconnecter l'utilisateur... les mois (février par exemple)...


Slt,

je rencontre ce problème régulièrement et je n'en comprends pas vraiment la cause.

question: pourquoi proposer un choix entre iso.8859-1 (implicite) et UTF-8 si c'est le souk au niveau des accents dès lors que l'on passe en UTF-8 dans metalang?
Et c'est le super-souk si l'on est contraint de le faire en cours de route.
Au démarrage, ça passe encore sans trop de bobos.

Rappel: dans ce cas, seuls les accents codés "en dur" sont affectés mais pas le contenu de la BdD.
La solution, je la connais: encoder en UTF-8 sans BOM les sources php concernée mais c'est fastidieux.
Et je ne parle pas des releases...
Chez free, par exemple, aucun problème de laisser le charset 8859-1
Chez d'autres hébergeurs (c-webh par exemple), c'est la galère...
Problèmes d'accents avec charset = 8859-1

Une idée sur le pourquoi?
merci d'avance pour vos lumières.

PS: A ce propos, je lis souvent : "UTF-8 n'est pas conseillé si on (n') utilise (que) le Français et/ou l'Anglais: PHP ne supporte pas en natif les caractères multi-octets, ça nécessite alors la compilation de l'extension mbstring".

  Profil  Citation   
developpeur
24560       
 

developpeur
  Posté : 26-03-2013 21:02

Citation : gregland 

Attend...
Pour l'UTF8, je pensais que tu parlais de la Bdd (l'import de ma base), mais je suppose que tu parlais de l'option dans Admin/MetaTags) et effectivement, je n'étais pas en UTF8, mais en iso88591...

Donc le problèùe est réglé comme celà pour les titres du Flux..., mais par contre, je me retrouve avec des textes (pas dans les articles, mais dans les termes de NPDS qui sont plus au bon encodage, comme par exemple le mot "déconnexion" pour déconnecter l'utilisateur... les mois (février par exemple)...

C'est cool tu as géré... maintenant je dois corriger ce nouveau problème...

Message édité par : gregland / 26-03-2013 01:13


Message édité par : gregland / 26-03-2013 01:13

 

Attention / passer en UTF8 pour regler le problème des titres RSS n'est PAS une bonne solution pour moi - car effectivement il vas falloir ensuite tous mettre en UTF8 !

Il j’agissais de savoir si cela avait un lien avec l'encodage / je te conseil de remettre le charset d'origine pour l'instant

  Profil  E-mail  www  Citation   
developpeur
24560       
 

developpeur
  Posté : 26-03-2013 21:06

Citation : bartok 

Citation : gregland 
par contre, je me retrouve avec des textes (pas dans les articles, mais dans les termes de NPDS qui sont plus au bon encodage, comme par exemple le mot "déconnexion" pour déconnecter l'utilisateur... les mois (février par exemple)...


Slt,

je rencontre ce problème régulièrement et je n'en comprends pas vraiment la cause.

question: pourquoi proposer un choix entre iso.8859-1 (implicite) et UTF-8 si c'est le souk au niveau des accents dès lors que l'on passe en UTF-8 dans metalang?
Et c'est le super-souk si l'on est contraint de le faire en cours de route.
Au démarrage, ça passe encore sans trop de bobos.
==> Effectivement c'est un choix à faire DES les démarrages ensuite c'est presque insoluble pour moi !

Rappel: dans ce cas, seuls les accents codés "en dur" sont affectés mais pas le contenu de la BdD.
La solution, je la connais: encoder en UTF-8 sans BOM les sources php concernée mais c'est fastidieux.
Et je ne parle pas des releases...
Chez free, par exemple, aucun problème de laisser le charset 8859-1
Chez d'autres hébergeurs (c-webh par exemple), c'est la galère...
Problèmes d'accents avec charset = 8859-1

Une idée sur le pourquoi?
==> ??? - c'est complétement anormal en fait ???

merci d'avance pour vos lumières.

PS: A ce propos, je lis souvent : "UTF-8 n'est pas conseillé si on (n') utilise (que) le Français et/ou l'Anglais: PHP ne supporte pas en natif les caractères multi-octets, ça nécessite alors la compilation de l'extension mbstring".
==> mbstring consomme un max de ressource tous simplement

  Profil  E-mail  www  Citation   
gregland
33    

gregland
  Posté : 26-03-2013 21:19

Ok ça marche, je vais remettre ça en iso.8859-1
Mais le problème vient de la en tout cas...

  Profil  Citation   
developpeur
24560       
 

developpeur
  Posté : 26-03-2013 21:30

pas certains ... NPDS.org n'est pas en UTF8 - par contre ton hébergeur c'est qui ?

  Profil  E-mail  www  Citation   
Aller à la page : [ 1 | 2 | 3 ]
  
Sauter à :

Temps : 0.0183 seconde(s)