Gestion de Contenu, de Communauté et de groupes de travail collaboratif - Open Source, français, sécurisé, stable et performant

  • MODULES

    Pour étendre les nombreuses fonctionnalités disponibles de base - modules.npds.org est à votre disposition.

    Des modules complémentaires, une communauté de développeurs active, des forums pour vos questions ... NPDS  est aussi une plateforme de développement !
  • STYLES

    Vous cherchez des thèmes graphiques pour votre portail ou votre communauté : styles.npds.org est à votre disposition.

    Des thèmes du plus simple au plus sophistiqué. Des thèmes facilement modifiables et toujours en Open-Source - Laissez simplement parler votre imagination !
  • BIBLES

    La documentation indispensable pour personnaliser et exploiter toute la puissante de NPDS  est à votre disposition sur bible.npds.org.

    Vous pouvez participer à l'effort de documentation - rien de plus simple : contactez un membre de la Team de développement et nous vous ouvrirons un compte sur le Wiki !
Devenir membre    |    Identifiant : Mot de Passe : -
Au delà de la gestion de contenu 'classique', NPDS met en oeuvre un ensemble de fonctions spécifiquement dédiées à la gestion de Communauté et de groupes de travail collaboratif.
Il s'agit d'un Content & Community Management System (CCMS) robuste, sécurisé, complet, performant et parlant vraiment français.

Gérez votre Communauté d'utilisateurs, vos groupes de travail collaboratif, publiez, gérez et organisez votre contenu grâce aux puissants outils disponibles de base.
  • Multi langues (Français, Anglais, Allemand, Espagnol, Chinois)
  • Respect des standards : UTF8, XHTML, CSS, ...
  • Système de blocs avancés
  • Installation et administration complète et centralisée
  • Editeur HTML intégré
  • Gestionnaire de fichier en ligne
  • Gestion des groupes de membres
  • Ecriture collaborative de documents (PAD)
  • Forums évolués
  • Mini-sites (pour les membres et les groupes de travail)
  • Chat temp réel
  • Système de News et de rubriques complet (édition, révision, publication)
  • ...
Gratuit et libre (Open-Source), développé en PHP, NPDS est personnalisable grâce à de nombreux thèmes et modules et ne requiert que quelques compétences de base.
NPDS Workplace - groupe de travail collaboratif
 NPDS WorkSpace - tous l'univers du travail collaboratif.
Modéré par : developpeur jpb Jireck 
Index du Forum » » Questions » » Date dans les articles  
3 pages [ 1 | 2 | 3 ]
AuteurDate dans les articles
PhilGuen
926      

PhilGuen
  Posté : 04-02-2014 08:22

J'ai un soucis avec la date dans les articles sur tous mes sites.

voir http://cyclos-descartes.org.

Dans les préférences l'heure locale est à fr_FR.UTF-8 et le charset en UTF8.

Ce qui est bizarre c'est que l'heure dans l'entête est au bien écrite.

Merci de vos conseils

Message édité par : PhilGuen / 04-02-2014 08:23


  Profil  E-mail  www  Citation   
Jireck
7992       

Jireck
  Posté : 04-02-2014 08:32

Pas compris ...
l'affichage est bon non ?

  Profil  www  Citation   
B-Mag
2343       
 

B-Mag
  Posté : 04-02-2014 08:59

slt

Non Février donne : Mardi 04 février 2014

  Profil  www  Citation   
PhilGuen
926      

PhilGuen
  Posté : 04-02-2014 10:08

Citation : B-Mag 

slt

Non Février donne : Mardi 04 février 2014 


Oui, c'est ca

  Profil  E-mail  www  Citation   
PhilGuen
926      

PhilGuen
  Posté : 04-02-2014 11:52

Le gros problème est que si je mets

fr_FR au lieu de fr_FR.UTF-8 dans les préférences, l'affichage de la date dans les articles devient correct, mais celui dans le header ne l'est plus Ce serait quand même bien que la même fonction/format soit utilisée partout. Y a quand même un sacré blème

Message édité par : PhilGuen / 04-02-2014 13:43


  Profil  E-mail  www  Citation   
developpeur
24560       
 

developpeur
  Posté : 04-02-2014 22:49

Celle (la date) de ton header (donc ton thème) est affichée via un !javascript!.

Donc clairement il est difficile d'aligner une fonction !javascript! avec une source php.

L'idée serait de remplacer celle de ton header je dirais

A suivre

  Profil  E-mail  www  Citation   
PhilGuen
926      

PhilGuen
  Posté : 04-02-2014 23:42

C'est !date! qui est utilisée dans le header (ca me le fait avec d'autres thèmes qui utilisent également !date!).Ce n'est pas une fonction !javascript!! Je me trompe?

  Profil  E-mail  www  Citation   
bartok
294     

bartok
  Posté : 05-02-2014 06:34

Citation : PhilGuen 
Le gros problème est que si je mets
fr_FR au lieu de fr_FR.UTF-8 dans les préférences, l'affichage de la date dans les articles devient correct, mais celui dans le header ne l'est plus Ce serait quand même bien que la même fonction/format soit utilisée partout. Y a quand même un sacré blème

Message édité par : PhilGuen / 04-02-2014 13:43

 

Pas faux! Nous en avions déjà parlé ici il y a plusieurs mois. La solution fr_FR.utf-8 avait été proposée. Oui, la date est gérée différemment selon l'endroit et ça ne simplifie pas les choses.

bizarre quand même que ce problème connu chez cet hébergeur depuis plus d'un an ressurgisse. Il faut dire que Martin (le grand manitou), n'a pas vraiment géré un phénomène qui semble propre à ses installations. c'est une des raisons pour lesquelles je suis allé voir ailleurs...

ce n'est pas lié au changement de son serveur puisqu'il a eu lieu il y a plusieurs mois...

En résumé:
install rev13 chez free: pas de pb de date
install rev13 par exemple chez shost: pas de problème
install rev13 chez cwebh: problème.

conclusion, ce serait sympa que martin vous donne un coup de main...
... et que dev nous dise si la date peut être gérée de manière unique.


  Profil  Citation   
PhilGuen
926      

PhilGuen
  Posté : 05-02-2014 08:29

Citation : bartok 

install rev13 par exemple chez shost: pas de problème

conclusion, ce serait sympa que martin vous donne un coup de main...
... et que dev nous dise si la date peut être gérée de manière unique.

 


sauf que moi j'ai exactement le même problème aussi chez shost que je suis en train de tester (et qui ne semble d'ailleurs pas fonctionner beaucoup mieux que c-webh) (et avec un autre thème d'ailleurs)

http://wgnt-elevage.shost.ca/Wgnt-Elevage/index.php?op=edito

(voir les articles du mois d'août)

N'est-il pas possible que le problème soit ré-apparu avec la MAJ vers REV13?

Message édité par : PhilGuen / 05-02-2014 08:33


  Profil  E-mail  www  Citation   
developpeur
24560       
 

developpeur
  Posté : 05-02-2014 21:49

ton premier site n'est pas en REv13 pour moi

Je me suis aussi trompé sur la date se trouvant dans ton header pour ton premier site / ce n'est effectivement pas en !javascript! mais via le meta !date!

le meta semble ne pas être complet en fait

Il manque(rais - à vérifier) le codage en utf-8 ... si le charset est UTF-8 ... comme ci dessous


   if (cur_charset=="utf-8") {
      $datetime = utf8_encode($dateti me);
   }


  Profil  E-mail  www  Citation   
PhilGuen
926      

PhilGuen
  Posté : 05-02-2014 22:04

Citation : developpeur 

ton premier site n'est pas en REv13 pour moi



Bah, si ... j'ai passé tous mes sites en REV 13 dont cyclos-descartes.org et c'est bien ce qui est indiqué en dessous du panel d'administration ainsi que par stats.php. Qu'est-ce qui te fait dire le contraire?

Je regarde pour modifier le méta ... mais faudrait faire un correctif pour les nouvelles versions non?

De toutes façons il y a un sacré bazar entre NPDS et UTF8 (voir par exemple les titres des forums sur guenet.org alors que le libelle dans les tables est correct, que les tables sont en UTF8 ainsi que le charset)!!!!

Message édité par : PhilGuen / 06-02-2014 00:34


  Profil  E-mail  www  Citation   
bartok
294     

bartok
  Posté : 06-02-2014 07:13

Citation : PhilGuen 
sauf que moi j'ai exactement le même problème aussi chez shost

Je n'obtiens âs le même résultat: rev13 installé chez shost avec heure locale=fr_FR:
février 2014 est correct dans les articles et dans le bandeau (si j'ajoute le méta date - version livrée - dans header.html du thème standard Mouse-IT2)


Message édité par : bartok / 06-02-2014 07:55


  Profil  Citation   
PhilGuen
926      

PhilGuen
  Posté : 06-02-2014 07:59

Citation : bartok 

Citation : PhilGuen 
sauf que moi j'ai exactement le même problème aussi chez shost

désolé d'apporter la contradiction mais rev13 installé chez shost avec heure locale=fr_FR: février 2014 est correct dans les articles et dans le bandeau (si j'ajoute le méta date - version livrée - dans header.html du thème standard Mouse-IT2)


Il suffit d'aller voir mon site ... peux-tu me donner le code de "ton" !date!


  Profil  E-mail  www  Citation   
bartok
294     

bartok
  Posté : 06-02-2014 12:27

Citation : PhilGuen 
Il suffit d'aller voir mon site ... peux-tu me donner le code de "ton" !date!

Je suis allé voir ton site et le mien et je ne peux que constater la différence...
je ne porte aucun jugement de valeur, bien entendu!
ce n'est pas "mon" date mais "LE" date livré avec la Rev13 du ... attends, je regarde.. 03.01.2014.
En apportant cette précision, je pensais juste aider à la compréhension. (dev, tu connais le chemin de "eval", tu pourras comparer)
bonne continuation!

PS: Je sais: ce souci dure depuis longtemps, longtemps, longtemps mais pour l'instant, je n'ai pas trouvé si c'était du ressort de NPDS ou de celui de certains hébergeurs (peut-être parce qu'ils ne sont pas sous unix)...

Message édité par : bartok / 06-02-2014 12:56


  Profil  Citation   
PhilGuen
926      

PhilGuen
  Posté : 07-02-2014 18:42

Citation : bartok 

ce n'est pas "mon" date mais "LE" date livré avec la Rev13 du ... attends, je regarde.. 03.01.2014.



Oui c'est bien entendu lol ... c'est juste pour vérifier s'il n'y a pas un mic-mac avec ma version ... donc si tu peux me donner le code ca permettrait de "pister" la différence. .. et si tu me donnes l'adresse de ton site, je pourrai peut-être m'en inspirer.

Merci d'avance

  Profil  E-mail  www  Citation   
Aller à la page : [ 1 | 2 | 3 ]
  
Sauter à :

Temps : 0.016 seconde(s)